Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Power Issue (Equinix Internet Access / Equinix Connect)
Incident Report for Equinix
Update
We are currently investigating hardware issue and we are working with our hardware providers to resolve the issue. .
ln6qj2rs2ss8

Incident Number: INC0045835
[Equinix Internet Access / Equinix Connect - APAC (ME)]
Posted Jun 29, 2024 - 16:27 UTC
Update
The issue has been identified and a fix is being implemented.
ln6qj2rs2ss8

Incident Number: INC0045835
[Equinix Internet Access / Equinix Connect - APAC (ME)]
Posted Jun 29, 2024 - 13:40 UTC
Identified
We are currently investigating this issue.
ln6qj2rs2ss8

Incident Number: INC0045835
[Equinix Internet Access / Equinix Connect - APAC (ME)]
Posted Jun 29, 2024 - 13:24 UTC
This incident affects: Equinix Internet Access / Equinix Connect - APAC (ME - Melbourne).