Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Metal Console Billing Account Page and the Metal API invoice endpoint are currently inaccessible (Equinix Metal)
Incident Report for Equinix
Resolved
This incident has been resolved.
[Equinix Metal - Global Services (API, Portal)]
Posted Feb 04, 2025 - 19:42 UTC
Investigating
We are currently investigating the issue.
[Equinix Metal - Global Services (API, Portal)]
Posted Feb 04, 2025 - 15:23 UTC
This incident affected: Equinix Metal - Global Services (API, Portal).