Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Hardware Failure (Network Edge, Equinix Fabric)
Incident Report for Equinix
Resolved
The power cable was re-seated. Card restored
Incident Number: 5-224541278931
[Equinix Fabric - Americas (NY); Network Edge - Americas (NY)]
Posted Mar 19, 2023 - 03:39 UTC
Investigating
Equinix SMC reported an issue with Equinix Fabric .
Incident Number: TBD
[Network Edge - Americas (NY); Equinix Fabric - Americas (NY)]
Posted Mar 01, 2023 - 05:48 UTC
This incident affected: Network Edge - Americas (NY - New York) and Equinix Fabric - Americas (NY - New York).