Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Link Failure (Equinix Fabric, Metro Connect)
Incident Report for Equinix
Resolved
Current Service Impact: None.

Latest update: Our provider advised that while they were working on a different circuit, they caused an unwanted interruption to our service.

Next Action: Incident will be closed.
Incident Number: 5-221825609468
[Equinix Fabric - EMEA (IL); Metro Connect - EMEA (IL)]
Posted Dec 08, 2022 - 02:12 CET
Investigating
Current Service Impact: Short service disruption during protection switch for customers in IL metro.
Incident Number: TBD
[Equinix Fabric - EMEA (IL); Metro Connect - EMEA (IL)]
Posted Dec 07, 2022 - 09:54 CET
This incident affected: Metro Connect - EMEA (IL - Istanbul) and Equinix Fabric - EMEA (IL - Istanbul).