Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Power Issue (Equinix Internet Access / Equinix Connect, Metro Connect, Equinix Fabric)
Incident Report for Equinix
Update
The issue has been identified and a fix is being implemented.
jgnhcm8qs0xw

Incident Number: INC0045886
[Equinix Fabric - EMEA (AM); Equinix Internet Access / Equinix Connect - EMEA (AM); Metro Connect - EMEA (AM)]
Posted Jun 30, 2024 - 09:58 UTC
Identified
We are currently investigating this issue.
jgnhcm8qs0xw

Incident Number: INC0045886
[Equinix Internet Access / Equinix Connect - EMEA (AM); Metro Connect - EMEA (AM); Equinix Fabric - EMEA (AM)]
Posted Jun 30, 2024 - 09:43 UTC
This incident affects: Equinix Fabric - EMEA (AM - Amsterdam), Metro Connect - EMEA (AM - Amsterdam), and Equinix Internet Access / Equinix Connect - EMEA (AM - Amsterdam).