Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Equinix Fabric Backbone Provider Link Issue (Equinix Fabric)
Incident Report for Equinix
Resolved
Equinix SMC monitored that the backbone link was stable since it recovered on 22-May 2023 at 23:11 hrs site local time. Backbone link provider confirmed that the sub-sea cable restoration has been completed.
Incident Number: 5-219733862204
[Equinix Fabric - Asia-Pacific (SG)]
Posted May 25, 2023 - 17:22 UTC
Identified
Equinix SMC monitored that one of Equinix Fabric backbone links between SG1 and HK1 is currently down.
Incident Number: 5-219733862204
[Equinix Fabric - Asia-Pacific (SG)]
Posted Mar 26, 2023 - 05:59 UTC
This incident affected: Equinix Fabric - Asia-Pacific (SG - Singapore).