Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Link Failure (Equinix Fabric)
Incident Report for Equinix
Update
The issue has been identified and a fix is being implemented.
ypgh2c6qjsk7

Incident Number: INC0043682
[Equinix Fabric - Americas (CH, DC)]
Posted Jun 12, 2024 - 21:14 UTC
Identified
We are currently investigating this issue.
ypgh2c6qjsk7

Incident Number: INC0043682
[Equinix Fabric - Americas (CH, DC)]
Posted Jun 12, 2024 - 20:58 UTC
This incident affects: Equinix Fabric - Americas (CH - Chicago, DC - Washington D.C.).