Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Link Failure (Equinix Fabric, Metro Connect)
Incident Report for Equinix
Resolved
Current Service Impact: None.

Latest update: Unforunately, neither our partner nor our local IBX Operation Technicians were able to determine RFO for this outage.

Next Action: Incident will be closed.
Incident Number: 5-221830310833
[Equinix Fabric - EMEA (ML); Metro Connect - EMEA (ML)]
Posted Dec 08, 2022 - 01:55 CET
Investigating
Provider’s name: Retelit
Incident Number: TBD
[Equinix Fabric - EMEA (ML); Metro Connect - EMEA (ML)]
Posted Dec 07, 2022 - 15:10 CET
This incident affected: Metro Connect - EMEA (ML - Milan) and Equinix Fabric - EMEA (ML - Milan).