Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Equinix Fabric Backbone Provider Link Issue (Equinix Fabric)
Incident Report for Equinix
Identified
Latest Update: Our backbone provider confirmed the circuit is affected by a fiber break and restoration details are yet to be determined.

Next Action: We will continue to follow up with the backbone provider for the estimated restoration date.
Incident Number: 5-219113639029
[Equinix Fabric - Asia-Pacific (HK)]
Posted Aug 03, 2022 - 08:02 UTC
Investigating
Equinix SMC monitored that one of Equinix Fabric backbone links between HK and LA is currently down.
Incident Number: 5-219113639029
[Equinix Fabric - Asia-Pacific (HK)]
Posted Jul 27, 2022 - 03:44 UTC
This incident affects: Equinix Fabric - Asia-Pacific (HK - Hong Kong).