Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Network Component Issue (Equinix Internet Access / Equinix Connect)
Incident Report for Equinix
Update
The issue has been identified and a fix is being implemented.
k98941cq93pr

Incident Number: INC0044960
[Equinix Internet Access / Equinix Connect - APAC (SG)]
Posted Jun 23, 2024 - 18:40 UTC
Identified
We are currently investigating this issue.
k98941cq93pr

Incident Number: INC0044960
[Equinix Internet Access / Equinix Connect - APAC (SG)]
Posted Jun 23, 2024 - 18:24 UTC
This incident affects: Equinix Internet Access / Equinix Connect - APAC (SG - Singapore).