Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Other (Metro Connect)
Incident Report for Equinix
Update
The issue has been identified and a fix is being implemented.
fkhlqtwfgm71

Incident Number: INC0045702
[Metro Connect - Americas (MT)]
Posted Jun 28, 2024 - 08:37 UTC
Identified
We are currently investigating this issue.
fkhlqtwfgm71

Incident Number: INC0045702
[Metro Connect - Americas (MT)]
Posted Jun 28, 2024 - 08:22 UTC
This incident affects: Metro Connect - Americas (MT - Montreal).