Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Network Component Issue (Equinix Fabric)
Incident Report for Equinix
Update
The issue has been identified and a fix is being implemented.
wpfttgdl0zml

Incident Number: INC0044612
[Equinix Fabric - EMEA (LD)]
Posted Jun 20, 2024 - 11:59 UTC
Identified
We are currently investigating this issue.
wpfttgdl0zml

Incident Number: INC0044612
[Equinix Fabric - EMEA (LD)]
Posted Jun 20, 2024 - 11:44 UTC
This incident affects: Equinix Fabric - EMEA (LD - London).