Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Provider Issue (Equinix Internet Access / Equinix Connect)
Incident Report for Equinix
Update
The issue has been identified and a fix is being implemented.
6bstkpzww9qj

Incident Number: INC0045930
[Equinix Internet Access / Equinix Connect - AMER (DE)]
Posted Jul 01, 2024 - 03:28 UTC
Identified
We are currently investigating this issue.
6bstkpzww9qj

Incident Number: INC0045930
[Equinix Internet Access / Equinix Connect - AMER (DE)]
Posted Jul 01, 2024 - 03:13 UTC
This incident affects: Equinix Internet Access / Equinix Connect - AMER (DE - Denver).