Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Equinix Fabric Backbone Provider Link Issue (Equinix Fabric)
Incident Report for Equinix
Resolved
Equinix Fabric Backbone Provider Link has been restore and remains stable as of 3/1/2023 12:17:26 AM EST.
Incident Number: 5-224518913203
[Equinix Fabric - Americas (AT)]
Posted Mar 19, 2023 - 03:38 UTC
Investigating
Equinix SMC monitored that one of Equinix Fabric backbone links between AT4 and DC2 is currently down.
Incident Number: TBD
[Equinix Fabric - Americas (AT)]
Posted Feb 28, 2023 - 14:27 UTC
This incident affected: Equinix Fabric - Americas (AT - Atlanta).