Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Link Failure (Network Edge)
Incident Report for Equinix
Resolved
Internal Incident only.
Incident Number: 5-217170883218
[Network Edge - EMEA (LD)]
Posted Jun 29, 2022 - 11:23 UTC
Update
Internal Incident only.
Incident Number: 5-217170883218
[Network Edge - EMEA (LD)]
Posted Jun 14, 2022 - 04:12 UTC
Identified
Internal
Incident Number: 5-217170883218
[Network Edge - EMEA (LD)]
Posted Jun 10, 2022 - 18:05 UTC
This incident affected: Network Edge - EMEA (LD - London).