Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Link Failure (Metro Connect)
Incident Report for Equinix
Resolved
Resolved
Incident Number: TBD
[Metro Connect - Americas (NY)]
Posted Apr 10, 2023 - 18:33 UTC
Investigating
Equinix SMC reported an issue with Fiber connect
Incident Number: TBD
[Metro Connect - Americas (NY)]
Posted Mar 27, 2023 - 23:44 UTC
This incident affected: Metro Connect - Americas (NY - New York).