Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Equinix Fabric Backbone Provider Link Issue (Equinix Fabric)
Incident Report for Equinix
Update
Latest: Our backbone provider is still awaiting update from their 3rd party provider for the estimated time of restoration (ETR).

Next Action: We will continue to follow up with the backbone provider.
Incident Number: 5-219113639029
[Equinix Fabric - Asia-Pacific (HK)]
Posted Aug 15, 2022 - 23:33 UTC
Identified
Equinix SMC monitored that one of Equinix Fabric backbone links between HK and LA is currently down.
Incident Number: 5-219113639029
[Equinix Fabric - Asia-Pacific (HK)]
Posted Aug 09, 2022 - 05:22 UTC
This incident affects: Equinix Fabric - Asia-Pacific (HK - Hong Kong).