Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Network Component Issue (Equinix Fabric, Metro Connect)
Incident Report for Equinix
Resolved
This incident has been resolved.
s05hdlhg72t5

Incident Number: INC0037511
[Equinix Fabric - EMEA (MA); Metro Connect - EMEA (MA)]
Posted Apr 27, 2024 - 13:38 UTC
Investigating
We are currently investigating this issue.
s05hdlhg72t5

Incident Number: INC0037511
[Equinix Fabric - EMEA (MA); Metro Connect - EMEA (MA)]
Posted Apr 25, 2024 - 11:27 UTC
This incident affected: Metro Connect - EMEA (MA - Manchester) and Equinix Fabric - EMEA (MA - Manchester).