Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Link Failure (Equinix Internet Access / Equinix Connect, Internet Exchange, Network Edge, Metro Connect, Equinix Fabric)
Incident Report for Equinix
Update
The network incident has been resolved and services returned to normal on 08-SEP-2023 05:40 Site Local Time.

This is the final update for the incident.
zntg6sb5s8yy

Incident Number: TBD
[Equinix Internet Access / Equinix Connect - AMER (NY); Internet Exchange - Americas (NY); Network Edge - Americas (NY); Metro Connect - Americas (NY); Equinix Fabric - Americas (NY)]
Posted Apr 10, 2024 - 16:34 UTC
Investigating
Engineers are currently providing optical support in the NY Metro. A technician accidentally unplugged the wrong circuit, and services may have experienced a brief downtime.
Incident Number: TBD
[Equinix Internet Access / Equinix Connect - AMER (NY); Internet Exchange - Americas (NY); Network Edge - Americas (NY); Metro Connect - Americas (NY); Equinix Fabric - Americas (NY)]
Posted Apr 10, 2024 - 16:22 UTC
This incident affects: Metro Connect - Americas (NY - New York), Internet Exchange - Americas (NY - New York), Equinix Internet Access / Equinix Connect - AMER (NY - New York), Network Edge - Americas (NY - New York), and Equinix Fabric - Americas (NY - New York).