Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Provider Issue (Equinix Fabric, Network Edge)
Incident Report for Equinix
Resolved
This incident has been resolved.
q1blsq45g48y

Incident Number: INC0054541
[Equinix Fabric - EMEA (LD) & Americas (TR); Network Edge - EMEA (LD) & Americas (TR)]
Posted Sep 03, 2024 - 14:06 UTC
Investigating
We are currently investigating this issue.
q1blsq45g48y

Incident Number: INC0054541
[Equinix Fabric - EMEA (LD) & Americas (TR); Network Edge - EMEA (LD) & Americas (TR)]
Posted Sep 03, 2024 - 13:51 UTC
This incident affected: Network Edge - EMEA (LD - London), Equinix Fabric - EMEA (LD - London), Network Edge - Americas (TR - Toronto), and Equinix Fabric - Americas (TR - Toronto).