Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Hardware Failure (Equinix Connect, Internet Exchange, Metro Connect, Equinix Fabric)
Incident Report for Equinix
Resolved
Current Service Impact: None.

Latest update: The power supplies are operational and stable.

Next Action: SMC will continue monitoring the situation.
Incident Number: 5-217432347720
[Internet Exchange - EMEA (MA); Metro Connect - EMEA (MA); Equinix Fabric - EMEA (MA); Equinix Connect - EMEA (MA)]
Posted Jun 06, 2022 - 13:13 UTC
Update
Current Service Impact: None

Latest update: SMC has not received an update from local IBX Team.

Next Action: SMC is still waiting for update.
Incident Number: 5-217432347720
[Equinix Fabric - EMEA (MA); Equinix Connect - EMEA (MA); Internet Exchange - EMEA (MA); Metro Connect - EMEA (MA)]
Posted May 27, 2022 - 05:06 UTC
Update
Current Service Impact: None

Latest update: Load was transferred back to utility source. IBX is still working with vendor with battery replacement.

Next Action: We are awaiting further updates from MA1 IBX team
Incident Number: 5-217432347720
[Internet Exchange - EMEA (MA); Metro Connect - EMEA (MA); Equinix Fabric - EMEA (MA); Equinix Connect - EMEA (MA)]
Posted May 24, 2022 - 17:52 UTC
Update
Current Service Impact: Some EF, IX, EC, MC customers in MA Metro could have experienced an outage of their services.

Latest update: Issue is related to IBX incident 5-217434657711. Power load was transferred to generators. IBX is still investigating issue and working to resolve it.

Next Action: We are awaiting further updates from MA1 IBX team
Incident Number: 5-217432347720
[Metro Connect - EMEA (MA); Equinix Fabric - EMEA (MA); Equinix Connect - EMEA (MA); Internet Exchange - EMEA (MA)]
Posted May 24, 2022 - 10:36 UTC
Identified
Provider’s name: Equinix

Current Service Impact: Some EF, IX, EC, MC customers in MA Metro could experience an outage of their services.

Latest update: Alerts are cleared and working properly.

Next Action: We are investigating RFO with IBX
Incident Number: 5-217432347720
[Equinix Fabric - EMEA (MA); Equinix Connect - EMEA (MA); Internet Exchange - EMEA (MA); Metro Connect - EMEA (MA)]
Posted May 24, 2022 - 09:47 UTC
Investigating
Current Service Impact: All EF, IX, EC, MC customers in MA Metro could experience an outage of their services.
Incident Number: 5-217432347720
[Equinix Connect - EMEA (MA); Internet Exchange - EMEA (MA); Metro Connect - EMEA (MA); Equinix Fabric - EMEA (MA)]
Posted May 24, 2022 - 09:31 UTC
This incident affected: Metro Connect - EMEA (MA - Manchester), Equinix Fabric - EMEA (MA - Manchester), Equinix Internet Access - EMEA (MA - Manchester), and Internet Exchange - EMEA (MA - Manchester).