Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Provider Issue (Equinix Fabric, Network Edge)
Incident Report for Equinix
Resolved
This incident has been resolved.
lk0x52709c6b

Incident Number: INC0054149
[Equinix Fabric - Americas (CH, DC); Network Edge - Americas (CH, DC)]
Posted Sep 01, 2024 - 14:47 UTC
Investigating
We are currently investigating this issue.
lk0x52709c6b

Incident Number: INC0054149
[Equinix Fabric - Americas (CH, DC); Network Edge - Americas (CH, DC)]
Posted Aug 30, 2024 - 21:17 UTC
This incident affected: Equinix Fabric - Americas (CH - Chicago, DC - Washington D.C.) and Network Edge - Americas (CH - Chicago, DC - Washington D.C.).