Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Link Failure (Metro Connect)
Incident Report for Equinix
Update
The issue has been identified and a fix is being implemented.
y409t9flr7rg

Incident Number: INC0028365
[Metro Connect - Americas (NY)]
Posted Feb 09, 2024 - 09:33 UTC
Identified
We are currently investigating this issue.
y409t9flr7rg

Incident Number: INC0028365
[Metro Connect - Americas (NY)]
Posted Feb 09, 2024 - 09:20 UTC
This incident affects: Metro Connect - Americas (NY - New York).