Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Provider Issue (Equinix Fabric, Network Edge)
Incident Report for Equinix
Resolved
This incident has been resolved.
5ly9sghr73s7

Incident Number: INC0054535
[Equinix Fabric - EMEA (PA) & Americas (CU, DA, DC); Network Edge - EMEA (PA) & Americas (DA, DC)]
Posted Sep 03, 2024 - 14:22 UTC
Investigating
We are currently investigating this issue.
5ly9sghr73s7

Incident Number: INC0054535
[Equinix Fabric - Americas (CU, DA, DC) & EMEA (PA); Network Edge - Americas (DA, DC) & EMEA (PA)]
Posted Sep 03, 2024 - 13:20 UTC
This incident affected: Equinix Fabric - Americas (CU - Culpeper, DA - Dallas, DC - Washington D.C.), Network Edge - Americas (DA - Dallas, DC - Washington D.C.), Network Edge - EMEA (PA - Paris), and Equinix Fabric - EMEA (PA - Paris).