Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Equinix Fabric Backbone Provider Link Issue (Equinix Fabric)
Incident Report for Equinix
Resolved
Equinix SMC confirmed that upstream provider link remained stable since it recovered on 18 October 14:43 hrs site local time. Our backbone provider confirmed the circuit that is affected by a fiber break has completed cable repair and restoration on 14 November at 03:00 hrs site local time.
Incident Number: 5-219113639029
[Equinix Fabric - Asia-Pacific (HK)]
Posted Nov 20, 2022 - 08:34 UTC
Identified
Equinix SMC monitored that one of Equinix Fabric backbone links between HK and LA is currently down.
Incident Number: 5-219113639029
[Equinix Fabric - Asia-Pacific (HK)]
Posted Nov 20, 2022 - 08:33 UTC
This incident affected: Equinix Fabric - Asia-Pacific (HK - Hong Kong).