Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Power Issue (Metro Connect, Equinix Fabric)
Incident Report for Equinix
Resolved
This incident has been resolved.
20426y0x82cz

Incident Number: INC0036228
[Equinix Fabric - Americas (MT); Metro Connect - Americas (MT)]
Posted Apr 16, 2024 - 11:20 UTC
Update
The issue has been identified and a fix is being implemented.
20426y0x82cz

Incident Number: INC0036228
[Equinix Fabric - Americas (MT); Metro Connect - Americas (MT)]
Posted Apr 15, 2024 - 21:44 UTC
Identified
We are currently investigating this issue.
20426y0x82cz

Incident Number: INC0036228
[Metro Connect - Americas (MT); Equinix Fabric - Americas (MT)]
Posted Apr 15, 2024 - 21:28 UTC
This incident affected: Metro Connect - Americas (MT - Montreal) and Equinix Fabric - Americas (MT - Montreal).