Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Provider Issue (Network Edge, Equinix Fabric)
Incident Report for Equinix
Resolved
This incident has been resolved.
w3ccdx82mx63

Incident Number: INC0054412
[Equinix Fabric - EMEA (GV); Network Edge - EMEA (GV)]
Posted Sep 11, 2024 - 21:07 UTC
Investigating
We are currently investigating this issue.
w3ccdx82mx63

Incident Number: INC0054412
[Network Edge - EMEA (GV); Equinix Fabric - EMEA (GV)]
Posted Sep 03, 2024 - 02:21 UTC
This incident affected: Network Edge - EMEA (GV - Geneva) and Equinix Fabric - EMEA (GV - Geneva).