Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Provider Issue (Equinix Fabric, Network Edge)
Incident Report for Equinix
Resolved
This incident has been resolved.
n31j1xx676rj

Incident Number: INC0036991
[Equinix Fabric - Americas (DC, NY); Network Edge - Americas (DC, NY)]
Posted Apr 22, 2024 - 00:06 UTC
Update
The issue has been identified and a fix is being implemented.
n31j1xx676rj

Incident Number: INC0036991
[Equinix Fabric - Americas (DC, NY); Network Edge - Americas (DC, NY)]
Posted Apr 21, 2024 - 19:38 UTC
Identified
We are currently investigating this issue.
n31j1xx676rj

Incident Number: INC0036991
[Equinix Fabric - Americas (DC, NY); Network Edge - Americas (DC, NY)]
Posted Apr 21, 2024 - 19:25 UTC
This incident affected: Equinix Fabric - Americas (DC - Washington D.C., NY - New York) and Network Edge - Americas (DC - Washington D.C., NY - New York).