Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Provider Issue (Equinix Fabric, Network Edge)
Incident Report for Equinix
Resolved
This incident has been resolved.
6npdy30p4660

Incident Number: INC0054542
[Network Edge - Americas (DA, DC); Equinix Fabric - Americas (DA, DC)]
Posted Sep 11, 2024 - 21:06 UTC
Update
The issue has been identified and a fix is being implemented.
6npdy30p4660

Incident Number: INC0054542
[Equinix Fabric - Americas (DA, DC); Network Edge - Americas (DA, DC)]
Posted Sep 03, 2024 - 14:22 UTC
Identified
We are currently investigating this issue.
6npdy30p4660

Incident Number: INC0054542
[Equinix Fabric - Americas (DA, DC); Network Edge - Americas (DA, DC)]
Posted Sep 03, 2024 - 14:06 UTC
This incident affected: Equinix Fabric - Americas (DA - Dallas, DC - Washington D.C.) and Network Edge - Americas (DA - Dallas, DC - Washington D.C.).