Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Internet Exchange Portal Availability
Incident Report for Equinix
Resolved
This incident has been resolved.
Posted Apr 15, 2024 - 13:30 UTC
Investigating
Equinix Internet Exchange® services on the IX Portal are currently experiencing intermittent issues. We are investigating and will advise once the issue has been resolved.
Posted Apr 15, 2024 - 12:51 UTC
This incident affected: Internet Exchange - Global Services (Portal).