Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Power Issue (Internet Exchange, Metro Connect, Equinix Fabric, Equinix Internet Access / Equinix Connect)
Incident Report for Equinix
Resolved
Equinix SMC confirmed that the services have been restored on 2 April 2024 at 17:14 UTC hrs.

Our engineers are still working closely with local operations for the validation of services and reports.

We are actively monitoring the stability of all services. .
dg7jdj7445db

Incident Number: INC0034596
[Equinix Internet Access / Equinix Connect - AMER (NY); Internet Exchange - Americas (NY); Metro Connect - Americas (NY); Equinix Fabric - Americas (NY)]
Posted Apr 09, 2024 - 23:00 UTC
Update
Equinix SMC confirmed that the services have been restored on 2 April 2024 at 17:14 UTC hrs.

Our engineers are still working closely with local operations for the validation of services and reports.

We are actively monitoring the stability of all services. .
dg7jdj7445db

Incident Number: INC0034596
[Equinix Fabric - Americas (NY); Equinix Internet Access / Equinix Connect - AMER (NY); Internet Exchange - Americas (NY); Metro Connect - Americas (NY)]
Posted Apr 06, 2024 - 06:16 UTC
Update
The Equinix SMC is working closely with local NY9 Operations to resolve remaining interface alarms..
dg7jdj7445db

Incident Number: INC0034596
[Equinix Fabric - Americas (NY); Equinix Internet Access / Equinix Connect - AMER (NY); Internet Exchange - Americas (NY); Metro Connect - Americas (NY)]
Posted Apr 03, 2024 - 00:05 UTC
Update
The Equinix SMC is continuing to monitor services for stability. We are also waiting for official root cause but our local site team.

We thank you for your understanding..
dg7jdj7445db

Incident Number: INC0034596
[Equinix Fabric - Americas (NY); Equinix Internet Access / Equinix Connect - AMER (NY); Internet Exchange - Americas (NY); Metro Connect - Americas (NY)]
Posted Apr 02, 2024 - 18:37 UTC
Update
NY9 experienced a power disruption that has been restored as of 02-04-2024 | 17:14:00 UTC Time.
At this time we are seeing services restore and are actively monitoring for stability.

We thank you for your patience and understanding..
dg7jdj7445db

Incident Number: INC0034596
[Internet Exchange - Americas (NY); Metro Connect - Americas (NY); Equinix Fabric - Americas (NY); Equinix Internet Access / Equinix Connect - AMER (NY)]
Posted Apr 02, 2024 - 17:30 UTC
Update
Current Service Impact: Under investigation

Latest update: NOC detected multiple devices in NY9 IBX going down.

Next Action: SMC is working to asses impact and determine what caused this issue..
dg7jdj7445db

Incident Number: INC0034596
[Equinix Fabric - Americas (NY); Equinix Internet Access / Equinix Connect - AMER (NY); Internet Exchange - Americas (NY); Metro Connect - Americas (NY)]
Posted Apr 02, 2024 - 16:50 UTC
Update
The issue has been identified and a fix is being implemented.
dg7jdj7445db

Incident Number: INC0034596
[Equinix Fabric - Americas (NY); Equinix Internet Access / Equinix Connect - AMER (NY); Internet Exchange - Americas (NY); Metro Connect - Americas (NY)]
Posted Apr 02, 2024 - 16:11 UTC
Identified
We are currently investigating this issue.
dg7jdj7445db

Incident Number: INC0034596
[Internet Exchange - Americas (NY); Metro Connect - Americas (NY); Equinix Fabric - Americas (NY); Equinix Internet Access / Equinix Connect - AMER (NY)]
Posted Apr 02, 2024 - 15:58 UTC
This incident affected: Metro Connect - Americas (NY - New York), Internet Exchange - Americas (NY - New York), Equinix Internet Access / Equinix Connect - AMER (NY - New York), and Equinix Fabric - Americas (NY - New York).