Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Network Component Issue (Equinix Fabric)
Incident Report for Equinix
Resolved
This incident has been resolved.
r9f74sn2t8f5

Incident Number: INC0036194
[Equinix Fabric - EMEA (HE)]
Posted Apr 18, 2024 - 08:48 UTC
Update
The issue has been identified and a fix is being implemented.
r9f74sn2t8f5

Incident Number: INC0036194
[Equinix Fabric - EMEA (HE)]
Posted Apr 15, 2024 - 12:56 UTC
Identified
We are currently investigating this issue.
r9f74sn2t8f5

Incident Number: INC0036194
[Equinix Fabric - EMEA (HE)]
Posted Apr 15, 2024 - 12:42 UTC
This incident affected: Equinix Fabric - EMEA (HE - Helsinki).