Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Provider Issue (Equinix Fabric, Network Edge)
Incident Report for Equinix
Resolved
This incident has been resolved.
d3mdlzf7g0vm

Incident Number: INC0037319
[Network Edge - EMEA (GV); Equinix Fabric - EMEA (BA, GV)]
Posted Apr 25, 2024 - 14:52 UTC
Update
The issue has been identified and a fix is being implemented.
d3mdlzf7g0vm

Incident Number: INC0037319
[Equinix Fabric - EMEA (BA, GV); Network Edge - EMEA (GV)]
Posted Apr 24, 2024 - 05:16 UTC
Identified
We are currently investigating this issue.
d3mdlzf7g0vm

Incident Number: INC0037319
[Equinix Fabric - EMEA (BA, GV); Network Edge - EMEA (GV)]
Posted Apr 24, 2024 - 05:00 UTC
This incident affected: Equinix Fabric - EMEA (BA - Barcelona, GV - Geneva) and Network Edge - EMEA (GV - Geneva).