Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Link Failure (Equinix Fabric)
Incident Report for Equinix
Update
CSP connections remains stable. Equinix SMC is investigating the issue with Vendor assistance. More updates will follow. .
g60cvjf36qsn

Incident Number: INC0037395
[Equinix Fabric - Americas (CH)]
Posted Apr 28, 2024 - 11:02 UTC
Update
Equinix SMC has observed several fluctuations in the CSP connections, which have shown instability. A more thorough examination will be conducted in collaboration with our IBX operations team, and the CSP will be reached out to for further investigation..
g60cvjf36qsn

Incident Number: INC0037395
[Equinix Fabric - Americas (CH)]
Posted Apr 24, 2024 - 15:11 UTC
Update
The issue has been identified and a fix is being implemented.
g60cvjf36qsn

Incident Number: INC0037395
[Equinix Fabric - Americas (CH)]
Posted Apr 24, 2024 - 14:54 UTC
Identified
We are currently investigating this issue.
g60cvjf36qsn

Incident Number: INC0037395
[Equinix Fabric - Americas (CH)]
Posted Apr 24, 2024 - 14:37 UTC
This incident affects: Equinix Fabric - Americas (CH - Chicago).