Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Power Issue (Metro Connect)
Incident Report for Equinix
Update
The issue has been identified and a fix is being implemented.
7y867hq64cbz

Incident Number: INC0035865
[Metro Connect - EMEA (HE)]
Posted Apr 11, 2024 - 20:56 UTC
Identified
We are currently investigating this issue.
7y867hq64cbz

Incident Number: INC0035865
[Metro Connect - EMEA (HE)]
Posted Apr 11, 2024 - 20:45 UTC
This incident affects: Metro Connect - EMEA (HE - Helsinki).