Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Link Failure (Internet Exchange)
Incident Report for Equinix
Resolved
This incident has been resolved.
6jw1v434pj9n

Incident Number: INC0036094
[Internet Exchange - Americas (NY)]
Posted Apr 16, 2024 - 13:22 UTC
Update
The issue has been identified and a fix is being implemented.
6jw1v434pj9n

Incident Number: INC0036094
[Internet Exchange - Americas (NY)]
Posted Apr 14, 2024 - 03:26 UTC
Identified
We are currently investigating this issue.
6jw1v434pj9n

Incident Number: INC0036094
[Internet Exchange - Americas (NY)]
Posted Apr 14, 2024 - 03:14 UTC
This incident affected: Internet Exchange - Americas (NY - New York).