Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

ML Network Connectivity Issue (Equinix Metal)
Incident Report for Equinix
Resolved
This incident has been resolved.
[Equinix Metal - Global Services (Network) & EMEA (ML)]
Posted Dec 06, 2024 - 01:21 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
[Equinix Metal - Global Services (Network) & EMEA (ML)]
Posted Dec 06, 2024 - 00:35 UTC
This incident affected: Equinix Metal - Global Services (Network) and Equinix Metal - EMEA (ML - Milan).