Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Power Issue (Internet Exchange)
Incident Report for Equinix
Resolved
This incident has been resolved.
5hnr5f8s6jlc

Incident Number: INC0036123
[Internet Exchange - Americas (NY)]
Posted Apr 16, 2024 - 10:34 UTC
Update
The issue has been identified and a fix is being implemented.
5hnr5f8s6jlc

Incident Number: INC0036123
[Internet Exchange - Americas (NY)]
Posted Apr 14, 2024 - 20:54 UTC
Identified
We are currently investigating this issue.
5hnr5f8s6jlc

Incident Number: INC0036123
[Internet Exchange - Americas (NY)]
Posted Apr 14, 2024 - 20:41 UTC
This incident affected: Internet Exchange - Americas (NY - New York).