Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Network Service Issue (Internet Exchange)
Incident Report for Equinix
Resolved
This incident has been resolved.
648w4lvc3fdp

Incident Number: INC0034314
[Internet Exchange - EMEA (BA)]
Posted Apr 03, 2024 - 05:57 UTC
Update
The issue has been identified and a fix is being implemented.
648w4lvc3fdp

Incident Number: INC0034314
[Internet Exchange - EMEA (BA)]
Posted Mar 31, 2024 - 10:00 UTC
Identified
We are currently investigating this issue.
648w4lvc3fdp

Incident Number: INC0034314
[Internet Exchange - EMEA (BA)]
Posted Mar 31, 2024 - 09:47 UTC
This incident affected: Internet Exchange - EMEA (BA - Barcelona).