Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Network Component Issue (Internet Exchange)
Incident Report for Equinix
Update
The issue has been identified and a fix is being implemented.
sy0kh4tl18qx

Incident Number: INC0041907
[Internet Exchange - Americas (MI)]
Posted Jun 04, 2024 - 21:31 UTC
Identified
We are currently investigating this issue.
sy0kh4tl18qx

Incident Number: INC0041907
[Internet Exchange - Americas (MI)]
Posted Jun 04, 2024 - 21:06 UTC
This incident affects: Internet Exchange - Americas (MI - Miami).