Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Network Component Issue (Equinix Internet Access / Equinix Connect, Internet Exchange, Metro Connect)
Incident Report for Equinix
Resolved
This incident has been resolved.
vf9pb85rv1k0

Incident Number: INC0054448
[Equinix Internet Access / Equinix Connect - EMEA (ML); Internet Exchange - EMEA (ML); Metro Connect - EMEA (ML)]
Posted Sep 11, 2024 - 21:06 UTC
Update
The issue has been identified and a fix is being implemented.
vf9pb85rv1k0

Incident Number: INC0054448
[Equinix Internet Access / Equinix Connect - EMEA (ML); Internet Exchange - EMEA (ML); Metro Connect - EMEA (ML)]
Posted Sep 03, 2024 - 07:43 UTC
Identified
We are currently investigating this issue.
vf9pb85rv1k0

Incident Number: INC0054448
[Equinix Internet Access / Equinix Connect - EMEA (ML); Internet Exchange - EMEA (ML); Metro Connect - EMEA (ML)]
Posted Sep 03, 2024 - 07:27 UTC
This incident affected: Equinix Internet Access / Equinix Connect - EMEA (ML - Milan), Metro Connect - EMEA (ML - Milan), and Internet Exchange - EMEA (ML - Milan).