Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Provider Issue (Network Edge, Equinix Fabric)
Incident Report for Equinix
Resolved
This incident has been resolved.
cc80xhkj4sp9

Incident Number: INC0054464
[Network Edge - EMEA (ML); Equinix Fabric - EMEA (ML)]
Posted Sep 11, 2024 - 21:06 UTC
Investigating
We are currently investigating this issue.
cc80xhkj4sp9

Incident Number: INC0054464
[Network Edge - EMEA (ML); Equinix Fabric - EMEA (ML)]
Posted Sep 03, 2024 - 08:29 UTC
This incident affected: Network Edge - EMEA (ML - Milan) and Equinix Fabric - EMEA (ML - Milan).