Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Network Service Issue (Equinix Internet Access / Equinix Connect)
Incident Report for Equinix
Update
The issue has been identified and a fix is being implemented.
83n46gvx78dz

Incident Number: INC0028497
[Equinix Internet Access / Equinix Connect - EMEA (AM)]
Posted Feb 11, 2024 - 07:48 UTC
Identified
We are currently investigating this issue.
83n46gvx78dz

Incident Number: INC0028497
[Equinix Internet Access / Equinix Connect - EMEA (AM)]
Posted Feb 11, 2024 - 07:35 UTC
This incident affects: Equinix Internet Access / Equinix Connect - EMEA (AM - Amsterdam).