Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Provider Issue (Equinix Fabric, Network Edge)
Incident Report for Equinix
Resolved
This incident has been resolved.
q73wjd467lcd

Incident Number: INC0054450
[Equinix Fabric - Americas (LA); Network Edge - Americas (LA)]
Posted Sep 03, 2024 - 08:44 UTC
Investigating
We are currently investigating this issue.
q73wjd467lcd

Incident Number: INC0054450
[Equinix Fabric - Americas (LA); Network Edge - Americas (LA)]
Posted Sep 03, 2024 - 07:27 UTC
This incident affected: Network Edge - Americas (LA - Los Angeles) and Equinix Fabric - Americas (LA - Los Angeles).