Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

ECP portal login page is not accessible
Incident Report for Equinix
Resolved
The issue impacting Equinix Customer Portal has been resolved.
Posted Dec 05, 2024 - 10:18 UTC
Monitoring
Customer Portal (ECP) Monitoring the fix
Posted Dec 05, 2024 - 10:14 UTC
Identified
ECP Team has identified the issue
Posted Dec 05, 2024 - 10:11 UTC
Investigating
We are currently investigating this issue.
Posted Dec 05, 2024 - 10:05 UTC
This incident affected: Equinix Customer Portal - Global Services (Portal).