Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Provider Issue (Equinix Fabric)
Incident Report for Equinix
Resolved
This incident has been resolved.
sbkbrtmx7087

Incident Number: INC0042969
[Equinix Fabric - Asia-Pacific (HK, SG)]
Posted Jun 15, 2024 - 08:05 UTC
Investigating
We are currently investigating this issue.
sbkbrtmx7087

Incident Number: INC0042969
[Equinix Fabric - Asia-Pacific (HK, SG)]
Posted Jun 06, 2024 - 13:08 UTC
This incident affected: Equinix Fabric - Asia-Pacific (HK - Hong Kong, SG - Singapore).