Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Provider Issue (Equinix Fabric)
Incident Report for Equinix
Resolved
Backbone Link between DC2 and CH1 is down. Equinix Engineers are currently investigating..
Incident Number: INC0020611
[Equinix Fabric - Americas (CH, DC)]
Posted Nov 24, 2023 - 05:07 UTC
Update
Backbone Link between DC2 and CH1 is down. Equinix Engineers are currently investigating..
Incident Number: INC0020611
[Equinix Fabric - Americas (CH, DC)]
Posted Nov 20, 2023 - 17:56 UTC
Identified
We are currently investigating this issue.
Incident Number: INC0020611
[Equinix Fabric - Americas (CH, DC)]
Posted Nov 20, 2023 - 17:46 UTC
This incident affected: Equinix Fabric - Americas (CH - Chicago, DC - Washington D.C.).