Welcome to Equinix service availability status page.

To view all notifications, log in to the Equinix Customer Portal. If you are experiencing an outage, log a trouble ticket or contact the Global Support Desk.

Link Failure (Network Edge)
Incident Report for Equinix
Resolved
This incident has been resolved.
hblqz1xlqzc7

Incident Number: INC0043425
[Network Edge - Americas (SV)]
Posted Jun 16, 2024 - 00:46 UTC
Update
The issue has been identified and a fix is being implemented.
hblqz1xlqzc7

Incident Number: INC0043425
[Network Edge - Americas (SV)]
Posted Jun 11, 2024 - 02:00 UTC
Identified
We are currently investigating this issue.
hblqz1xlqzc7

Incident Number: INC0043425
[Network Edge - Americas (SV)]
Posted Jun 11, 2024 - 01:45 UTC
This incident affected: Network Edge - Americas (SV - Silicon Valley).